42 70 Votes

How to get a UMTS/H/H+ network with your mobile phone?

Question by Guest | 08/01/2014 at 22:22

With interest, I have read your article about the different transmission standards GSM, EDGE, UMTS, HSPA and LTE.

According to the homepage of the manufacturer, I know, that my smartphone does not support LTE. Nevertheless, it should be possible to connect with the 3G-Network (UMTS or H and H+) that should be supported by my phone.

Despite this, I always just get only the symbols or icons for the GSM, GPRS or EDGE network on my phone (2G, G or E) which are the slowest connections you can have according to your table!

So, what can I do to make my phone also connecting to the faster UMTS network? Thank you.

ReplyPositiveNegativeDateVotes

E-Tinker

Show Profile | Message
Avatar
7Best Answer
9 Votes

There are two possible causes that your smartphone only connects to the slower 2G-Network:

  1. First, in the settings of your mobile phone, there is the possibility to specify the networks to which the phone is allowed to connect. Perhaps, this setting is set to "GSM Only" which means, that the phone is only allowed to use the GSM-2G-Network. Usually, you can find these settings under "Settings > Wireless & Networks > (More Settings > ) Mobile Networks". Here, the network mode should be set to "GSM/WCDMA(Auto Mode)". When set to "GSM Only", your mobile phone will not log into the UMTS network (which, however, has the advantage that it saves battery).
  2. If this does not help, it may also be that there is simply no UMTS network available in your area. There should be still areas, where the network structure is still not well developed. In this case, unfortunately, you cannot do anything else than asking your provider whether there are plans for upgrading the network in your area. But of course, you can also test the next time, you are in a greater city to see, if there is a better network displayed on your phone.

I hope I could help you and you can soon surf the internet faster with your smartphone. 
Last Update on 07/03/2018 | Created on 08/01/2014

ReplyPositive Negative
311 Votes

Your advice has been so helpful and I hope it will lead to a success towards us having a better internet services.

Thank you and hope you'll be around long enough to see us trough.
24/05/2015 at 16:31

Positive Negative
426 Votes

1. Go to Settings.
2. Go to More Settings under WiFi/Bluetooth/Data Usage
3. Go to Mobile Networks
4. Here you should get 3 options GSM/WCDMA(Auto Mode), GSM Only & WCDMA Only.
5. Select GSM/WCDMA(Auto Mode)

You should be good to go!
17/12/2014 at 10:57

ReplyPositive Negative
00 Votes

Thanks. I had switched to GSM/WCMD/AUTO on the phone network setting, yet my LTE Z835 will not give transmission signal even though it accepts the SIM card. I cannot call or receive. Now network access. Pls help.
28/02/2018 at 09:22

Positive Negative
Reply

Related Topics

Important Note

Please note: The contributions published on askingbox.com are contributions of users and should not substitute professional advice. They are not verified by independents and do not necessarily reflect the opinion of askingbox.com. Learn more.

Participate

Ask your own question or write your own articles on askingbox.com. How to do.